var luke_skywalker – Very good. The true name of the parent class came as quite the surprise. However, the way this variable is used right before garbage collection is pretty inconsistent with its use throughout the rest of the program. Please revisit.
var princess_leia – Change. Too hard to spell.
var HanSolo – Please remain consistent with CamelCase or snake_case. Feels like this variable is a bit of a rebel…
const EP7_THE_FORCE_AWAKENS – I think this one is a duplicate. How’s it different from EP4_A_NEW_HOPE (see line 1977)? Continue reading “Star Wars Code Review”