var luke_skywalker – Very good. The true name of the parent class came as quite the surprise. However, the way this variable is used right before garbage collection is pretty inconsistent with its use throughout the rest of the program. Please revisit.
var princess_leia – Change. Too hard to spell.
var HanSolo – Please remain consistent with CamelCase or snake_case. Feels like this variable is a bit of a rebel…
const EP7_THE_FORCE_AWAKENS – I think this one is a duplicate. How’s it different from EP4_A_NEW_HOPE (see line 1977)?
var darth_vader – Spelling? IDE is giving “anakin_skywalker” as suggested replacement. Please advise.
var the_force – Go ahead and leave off the “the”.
const EP8_THE_LAST_JEDI – We should switch to a strongly-typed language. This constant’s behavior is completely unexpected…I think it might have crashed the entire program and set my computer on fire…
var obi_wan_kenobi – Can we shorten this one a bit? A lot of typing. Maybe just ben?
var jar_jar_binks – Please use helpful names for your variables. I have no idea what this is or why it’s even here.
function yoda() – OK, but somehow different all the code in this function reads…
const EP9_RISE_OF_SKYWALKER – I think this one is incorrectly named. See the following code starting at line 2019:
IF (movie_name == EP9_RISE_OF_SKYWALKER)
Very confusing. Please advise.
// Misc. Notes – Overall @JJ, I don’t think the pair programming with @Rian is working out. Management would like to kick this one back to @george_lucas_1944 and redo the work on 7-9.
Thanks to you both for your effort here though. I’m sure some of what you’ve done will be re-usable in the final production build. As things now stand, we’ll call this try an alpha attempt and be sure to write some glowing references for you guys as you move on to other projects…hopefully in galaxies far, far away from Star Wars.